Using your Google Account

Signing in for the first time

There are several advantages to linking your Google Account to Mindmatters. You can manage files directly from Google Drive, create new diagrams as well as save and share content without restriction as well is quickly import image resources etc. You can attach one or more spreadsheets to your diagrams and create front end, data driven templates. You can synchronize data across devices and you can publish creations to our hosting servers with a permanent URL.

The Google "sign in" and "sign out" buttons are located in the message bar, above the App.

Google Buttons
Connect Your Google Account

The first time you use your Google Account to sign in to Mindmatters you will be asked to grant the necessary permissions. Mindmatters only uses your account information to manage the app and does not disclose information to third parties.

Google Signin
Allow Permissions

When the sign in process is complete a message will be logged.

Google Signin
Message Log

Working locally or on Google Drive

When you create a new diagram from within Mindmatters, the data is stored within your browser and Google Drive is not used. It can be converted by exporting the file to Google Drive and opening it from there. Likewise files can be imported from Google Drive and be converted to locally stored file types.

Users can create a blank Google Drive file from the Google Drive user interface once Mindmatters has been granted your sign in permissions.

Google Drive New
Create a New File in Drive

There are obvious advantages to working with Google Drive files. They are easier to share and not subject to data loss when Browser storage is cleared. There are some advantages too, though, from merging from the library locally.

Backing up creations and storing final versions in Google Drive while retaining only required content locally will speed loading times and aid performance.

Switching between types

Exporting local files

Choose Google Drive during the export process will create a new file called "Export.mmcf" in the root folder of your Drive account. When the export has been completed you will get a system message and the file will appear in your Drive view.

Google Msg
Export success
Google Drive
Google Drive

Note: The created Export is a snapshot, your current open version will remain the version you are editing. Open the newly created Export to work with the Google Drive file.

Importing Google Drive files

temporarySECTION WILL REMAIN INCOMPLETE PENDING A FEATURE ADDITION / BUG FIX

Adding a Spreadsheet as a Data Source

Users can connect and disconnect data sources to their diagrams from the Main Control Panel

Data Source
Manage Data Sources

From the data manager (and while logged in to a Google Account) pressing the "pick" button will open the Google file picker. Select the spreadsheet you wish to use as a data source.

Data Source Form
Data Source Management

The sheet tabs of the selected spreadsheet will populate the "Sheet Name" drop down list. Use the "Add Source" button to add every/any desired sheet. There are no fixed limits to the number of spreadsheets or spreadsheet pages that you can add. Data from any ranges within these sheets can be used to populate text, tables and charts.

Data Source Form
Data Source Management

Swapping Data Sources

Data Sources can be swapped, sheet by sheet, to enable swift updates when creating presentation templates. Eg Monthly Reports where the spreadsheet structure is identical

Select the source to be changed in the "From" drop down and the source with which it is to be replaced in the "To" drop down and click "Swap Source". All data references will be automatically updated.

Setting data from a spreadsheet range

Text, Tables and Charts (Series and Axis) can all be linked to read spreadsheet data. When presented with the option to read a data source, the Data menu is shown

Data Menu
The Data Menu

Data can be set manually from this menu, or users can choose to add a range from a Data Source linked to the digram.

Data ranges are entered as they would be in Excel/GoogleSheets using A1 notation. Ie A two column, ten row range may be A1:B10

When spreadsheets are updated, Mindmatters requests a change flag and updates were the new data is received from Google Drive. You can force an update by repeating the data setting process.

temporaryNamed Ranges and Static data options are not yet implemented.

Data Menu
Linked Data

Setting text from a range

After setting a text to read from a datasource the text control will be updated but disabled and manual entry will not be possible.

Text Edit Menu
Text Control Disabled

To re-enable manual editing set the text's data source to "No Source".

Working with Tables

Editing Tables

When a table component is added to an existing shape, it has a number of default settings (and data) that can be changed with the Table Editor Menu

Table Editing Menu
The Table Editor

The top section of controls controls how the Table behaves as the shape is resized, like other component types

Table Editing Menu

The next section contains the set data command that will allow you to set a data source or enter data manually (see below for more information). Additionally row and column data can be flipped for easy formatting.

Table Editing Menu

This section of controls deals with the appearance of the cells, rows and columns of the table. First users can decide to apply the "header" style to either, neither or both of the first row or column.

Users can also set a "corner" angle, similar to rounded rectangular shapes they form cells with rounded corners corresponding to the values set. Users can set spacing, to create a separation between rows and/or columns.

Finally, from this section, users can set the border colour and widths of "ordinary" cells as well as highlighted rows (table highlighting applies to published creations and more details are contained in later topics).

Table Editing Menu

The next section of controls determines the width and height distributions of individual rows and columns as a proportion of the table's height and width.

By default both columns and rows are distributed automatically. To change this, untick either or both tick boxes.

Then replace any "a" (automatic) with a value between 1 and 100 indicating the percentage of available space that row or column should occupy.

Table Editing Menu

Controls completed as they are in this example would describe a table with equally distributed rows. The first column occupying 50% of the table with and the remaining two columns sharing the remaining 50% space.

Table Editing Menu
Table Editing Menu

The final section contains the row styling controls. From here the fill and text styles for differing rows can be created. Creating multiple base styles will cause them to be reused consecutively; this allows the creation of single style tables, alternating lines or more complex repeating colours.

Table Editing Menu

Using Multiple Styles and Multiple Tables

Shapes can contain multiple tables and diagrams can hold as many shapes as you need. So highly stylized designs can be created by combining multiple tables and/or shapes.

This example shows a simulated colour chart by combining multiple charts in a single shape, setting percentage heights and widths and then using the "order" positioning commands.

An Example of Multiple Tables
Multiple tables in a single shape

Setting Table Data Manually

As for all items that can be connected to a data source, it is also possible to enter data manually. For tables each row (including any header row data) is surrounded by square brackets with each row separated by a comma. Each cell within a table is also separated by a comma. Data for this table can be entered as [Heading A,Heading B,Heading C],[1,2,3],[4,4,4],[5,6,7],[8,9,10],[11,12,13]

temporaryManually entering incorrectly formatted data can result in a error requiring a page refresh.

An Example Table
A Table With Manually Entered Data

Blank Entries and Empty Data Ranges

Empty rows and columns in Excel or Google Sheets spreadsheets are always included as empty cells in MindMatters tables. To trim blank lines the range reference would need to be updated.

Manually entering data, however, even retaining the data string generated by reading the spreadsheet, will see blank rows (empty square brackets) ignored.

To maintain blank rows add a non printing, like a space, to the empty brackets.

An Example Table
Blank Data From a Spreadsheet

new Conditional Row Formatting

Conditional statements can be applied to Table row formats. When ...

Working with Charts

Editing Charts

There are several elements to the chart editing menu. This figure shows the settings for an example pie charts and the following section will break each part down with instructions on how to implement all different options.

Chart Editor
The Chart Editor Configured for a Pie Chart

The top section of the control sets the size of the chart, proportional to the shape and whether it should resize as the shape does.

Chart Editor

Chart Axis

The mid section contains all controls relevant to the charts axes.

Chart Editor

A chart can contain multiple axis and they can be selected, added and deleted from these controls. The settings for the axis currently selected in the dropdown are displayed on the form.

Multiple axis support showing series on the same chart, at two different scales.

Chart Editor

The axis scale and labels button will open a new form (details below) and the buffer control gives an additional fine tune option for charts on linear scales to help prevent series markers overflowing the plot area. The buffer will effect all series on the selected axis.

Chart Editor

A chart axis can be one of two types; Linear (line) or Radial. Linear axis are the most common type and are used for everything from most common chart types (line, area, bar charts, scatterplots etc).

Radial plots are used for circular axis, like pie charts and spider plots.

Chart Editor

Swapping axis (on a Linear axis) will cause data to be plotted along the y axis, instead of along the x axis. This example shows a switched axis. With markers changed from "Columns" to "Bars".

Chart Editor

Stacking Axis and Fixing Y Values

Stacking axis (on a Linear axis) causes series values to be cumulatively added. This allows all series to be converted stacked series chart plots.

Chart Editor

Fixing Y-Values serves a number of purposes. With stacked series fixing Y values turns the chart into a proportional stacked series.

SeriesValues
Stacked A12,10,8,10,15,14,13,13
Stacked B8,5,18,12,5,4,8,15
Total20,15,26,22,20,18,21,28

Becomes

SeriesValues
Stacked A Fixed60%,67%,31%,45%,75%,78%,62%,46%
Stacked B Fixed40%,33%,69%,55%,25%,22%,48%,54%
Total100%,100%,100%,100%,100%,100%,100%,100%
Chart Editor

Pie Charts also rely on having Fixed Y Plot values to display properly.

Chart Editor
Pie Chart with and without Fixed Y Values

Axis Minimum, Maximums and Graphics

Axis value parameters can be set from this section. There are a combination of methods to set minimum and maximum display. It is generally safest to fix the minimum value at 0 and allow the chart to automatically rescale based on data by providing no maximum value parameters (ie leaving blank fields)

Chart Editor

Axis graphics gives a limited range of axis customisation options for Radial Axis types. The colour and thickness of the plot points can be shown for charts like spider plots. Or hidden for Pie Charts.

Chart Editor

Chart Axis Scales and Labels

Clicking the "Edit Axis Scale and Labels" button opens a new menu.

The Axis Scale controls the display of Y Axis values, including font size and position. The Axis Scale Interval dictates the spacing and frequency of the labels. Ie a scale interval of "5" would have a label for every five units on the Y Axis.

Axis display lines can be controlled in the same way via the Line Interval control.

Chart Editor

Labels control the X Axis plot labels. Names can be entered manually (each entry separated by a comma) or they can be linked to a spreadsheet range.

Chart Editor

Chart Axis Data

Data can be assigned to the X Axis in addition to, or instead of, Y Axis. Pie Charts and Scatterplots require X Axis data. The Axis data copies data from any provided data if none is set (ie for easy Pie Chart creation).

Chart Editor
Chart Editor
Pie Chart, Pie Chart without X Axis Data, Pie Chart without X Data or a Fixed Y Axis

Axis data can also be set from a Data Source or entered manually. Axis and Series data should be a comma separated list of numerical values.

Chart Series

A list of series plotted on any axis in the chart and the option to add additional series is shown at the bottom of the main chart editing form. Basic editing options are provided for each series (the axis on which the series is plotted, the basic display type and basic marker type) as well as the option to open the Series Editor form for each series for a greater range of configuration options.

Series data can also be accessed and set from this area.

Chart Editor

Chart Series Editing

The Series Editor offers a more complete range of options than the Chart Editor. From here data can be set, the series can be deleted or the user can return to the Chart Editor. The Form is otherwise in three sections; Display Settings, Series Marker Settings and the Data Point Editor.

Series Editor
The Series Editor
Series Display Settings

The plot type can be set from the Display section to either None, a Line or an Area. Colour and size can also be set.

The "Plot Start" control allows users to alter the first position of the series drawing point.

"Auto Colour" means that a series (and/or the series markers) mean that new series are auto colored in fixed sequence. Colour settings cannot be edited unless Auto Colour is turned off.

Chart Series
Three Identical Series With Variable "Plot Starts"
Series Markers and Data Points

The Data Markers sections contains a number of controls that allow a number of pre-configured markers to mark data points. Some markers are suited for use with other chart options. Ie Radial Pins or Pie Slices on charts with a Radial Axis. Or Bars on x-Axis plotted charts compared to Columns for standard linear axis. See the Plot Types and Settings Reference guide below for full details.

Data point markers uses optional Auto Colouring, but also has an additional "Match All" control. With Auto Colour turned on, but Match All turned off each data marker will have distinct fill and line colours.

Editing series markers will over ride any individual settings you may have set. It is advisable to complete changes to this section, before editing individual markers.

Chart Series
Column markers with Colour Matching Off

Through the Marker Editor form the marker for each individual point can be customised with options similar to those for Markers in general.

In addition to the standard options, it is also possible to set an uploaded image as a Data Point marker. After selecting an image from the image library, the size and position can be set from this form.

Marker Edit

Chart Series Data and Data Labels

Chart Series Data can be entered manually or linked to a Datasource Range using methods previously described. Manually entered data should be a list of comma separated, numerical values

Data labels can be displayed instead of, or in addition to, graphical marker points. As well as font and position controls users are also able to use a number of special characters that will be calculated from the data set.

Data Labels
Special CharacterReplacement Value
<<v>>Replaced with the data point value
<<cv>>Replaced with the cumulative value of series values at this data point (for this axis)
<<%a>>Replaced with the % of the total for this datapoint as a proportion of this axis
<<%s>>Replaced with the % of the data point as a proportion of the series total

Common Chart Plot Types and Settings Reference

Popular chart choices, and the settings needed to create them, are given below. Note, this is not an exhaustive list and other combinations are possible.

Plot Type Axis Swap Axis Stack Series Fix Y Values Data xAxis Plot Type Markers Preview
Column Chart Linear No No No No None Columns Sample 1
Bar Chart Linear Yes No No No None Bars Sample 2
Stacked Bar/Column Chart Linear Match above Yes No No No Match above Sample 3
Stacked (%) Bar/Column Chart Linear Match above Yes Yes No No Match above Sample 4
Line Chart Linear No No No No Line None Sample 5
Area Chart Linear No No No No Area None Sample 6
Stacked Area Chart Linear No Yes No No Area None Sample 7
Stacked Area % Chart Linear No Yes Yes No Area None Sample 8
Scatter Plot Linear No No No Yes None X Sample 9
Gauge Chart Linear No No No No None Columns Sample 10
Pie Chart Radial No No Yes Yes None Pie Slices Sample 11
Radar Chart Radial No No No No Line None Sample 12